Microsoft Support Number OR Call Toll-Free @ 1-844-478-2887

Thursday, September 16, 2010

Access 2010 Gotchas

Compatibility between Access 2007 and Access 2010

New Access 2010 features such as Data Macros and Calculated Column sare not compatible with Access 2007. To prevent data loss or corruption Access 2010 will make changes to an ACCDB that will prevent it from being opened in Access 2007 or make it as read-only in Access 2007.

According to a Post on the Access Team Blog, Access 2007 cannot open a database built or modified in Access 2010 if it uses:
  • the Access 2010 sort order feature,
  • Access 2010 encryption, or
  • the application has been published to SharePoint.
Other new features such as Data Macros , Calculated Columns , Navigation controls, Web browser controls, and new layouts for forms and reports, are supported as read-only in Access 2007 SP2.

Features Not Supported in Access 2010

Another Post at the Access Team Blog provides an overview of features and components that will be not be supported in Access 2010:
  • Calendar Control (mscal.ocx) The calendar control will not be shipped with Access 2010. If you open a form that inlcudes the mscal.ocx control you will see the following error: “Your Microsoft Office Access database or project contains a missing or broken reference to the file 'MSCAL.OCX’.” To fix this issue, you will need to remove the control and use The Access Date-picker or a 3rd-party control.

  • Report Snapshot Format In Access 2010, snapshot format for reports will not be available.

  • Data Access Pages (DAPs) In Access 2007 legacy DAPs were run-only. In Access 2010, DAPs are completely removed. They will be listed in navigation pane but if user attempts to open them, they will see the following error: “Microsoft Office Access does not support this operation for Data Access Pages. To perform this operation, use Microsoft Office Access 2007 or earlier.”

  • Paradox (3, 4, 5, 6, 7) ISAM, Lotus 1-2-3 ISAM and Red 2 ISAM or Jet 2 Export, import and linking to data from Paradox 3, 4, 5, 6, 7, Lotus 1-2-3, Access 1.0 and 2.0 (Red 2, or Jet 2) will not be available in Access 2010. User may see the following error: Installable ISAM not found. You will need Access 2007 or older in order to be able to export, import or link data from Paradox 3, 4, 5, 6, 7, Lotus 1-2-3, Access 1.0 and 2.0 (Red 2, or Jet 2) files.

  • Replication Conflict Viewer In Access 2007 and before, the Replication Conflict Viewer enabled users to visually display synchronization conflicts and enable resolution. The Viewer will not be shipped in Access 2010. As a workaround, you can write your own custom conflict resolution functions and mark them on the ReplicationConflictFunction property in the database replica set. Here is a link that describes how to set property so that you can create a custom procedure to resolve conflicts: http://support.microsoft.com/kb/158930.

Source :-http://accessextra.blogspot.com/

For More Detail
Microsoft Access 2010 Whats Exclusive



Post a Comment